On February 11th, 2014, Microsoft released Cumulative Security Update, MS14-010.  This security update causes Internet Explorer 11 to crash when an instructor accesses any Blackboard Learn course that has Edit Mode turned on.  This security update was pushed (by Microsoft) to all Windows users with IE11.  More information about the security update can be found here:

http://technet.microsoft.com/en-us/security/bulletin/ms14-010

Blackboard technical support has identified a workaround for this issue, and we will be implementing it into UTC’s Blackboard environment on 14 March 2014.  However, please remember that Internet Explorer 11 is NOT a supported browser for our version of Blackboard.  The Walker Center for Teaching & Learning continues to recommend that all Blackboard users utilize the most current versions of Mozilla Firefox or Google Chrome.

Blackboard Supported Browsers

http://help-archives.blackboard.com/Blackboard-Learn/9.1/SP09/EN-US/NAHE/Student/Content/_about/about_browsers.htm

Mozilla Firefox

http://www.mozilla.org/en-US/firefox/new/

Google Chrome

https://www.google.com/intl/en/chrome/browser/

 

Leave a Reply

Your email address will not be published. Required fields are marked *

*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>